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Introduction

Introduction

erwin Data Modeler (DM) and erwin Mart Server 12.0 support CURL commands and REST
APIs that enable report generation based on predefined XML report definitions shipped with
the Mart Server. The predefined report definition, reports.xml, is available at C:\Program
Files\erwin\Mart Server r9\Tomcat64\webapps\MartServer\WEB-INF\classes\.

Using these reports, you can generate XML reports for the following objects that are stored
in the Mart:

" Catalog Information
" Model objects and their properties
" Users
" Lock information
" Profiles
u . .
Permissions

For more information on report types, refer to the Types of Reports topic.

| ?? You can generate REST reports only if you are a Server user.

This section contains the following topics

Architecture

Generate Reports using a Reporting Tool
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Architecture

Workflow
When you generate a report, data is retrieved from the Mart Server via CURL commands or
REST APlIs.
The components involved in reporting are as follows:

* CURL commands or REST APIs

" Predefined XML-based report definitions

" Mart Server

® Mart database, which is the data source for the Mart Server
The following steps describe the report generation process:

1. Authenticate yourself using your Mart Server credentials and generate a bearer token.

2. Use CURL commands or REST APl endpoints to connect to the Mart Server using a
bearer token.

3. Generate the required predefined report in the XML format.
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Generating Bearer Token

Generating Bearer Token

REST reports generation from Mart requires a bearer token in order to authenticate your-
self. Once generated, you can reuse this token to generate multiple reports.

To generate a bearer token, follow these steps:

1. Log on to erwin Mart Administrator.

= el’Wlﬁ Mart Administrator

2.

3.

E erwin Inc

To protect and improve our data assets and enable data
transparency

On the top pane, cIick.

The Mart Reporting APl page opens.

EEEGEL LU Generate Report Using Bearer Tokens ~

Mart Reporting API

http:Mocalhost: 18170MariServer/iv3fapi-docsTgroup=Generate Report Using Bearer Tokens

Servers

[ http:/llocalhost: 18170 - Inferred Url  ~

report-controller Report Controller

Authorize g |

In the Select a definition field, select Generate Report Using Bearer Tokens.
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Generating Bearer Token
4. Expand the report-controller section. Then, click the POST section.

report-controller Report Controller v
/MartServer/api/report/authenticate authenticate a8

Mo parameters

Request body application/json w ]

Example Value | Schema

i

"password”: "string”,

"username”: "string™

1
I

5. Click Try it out.
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Generating Bearer Token

re pOFt-CO ntroller Report Controller ~

20 /MartServer/api/report/authenticate authenticate e

Parameters Cancel

Mo parameters

Request body application/json ~ ]

{
"password”: "string",
"username": "string"

1

6. Inthe Request body section, enter your Mart username and password.

7. Click Execute.
The CURL command and bearer token are generated in the Responses section.
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Generating Bearer Token

Responses

Curl

curl -X POST “http://localhost:18178/MartServer/api/report/authenticate™ -H "accept:
*/+#" _H "Content-Type: application/json™ -d "
{\"password\":\" AL W Usernamey " s\ T e gt

Request URL

http: //localhost:18178/Mart5erver/api/report/authenticate

Server response

Code Details

=l Response body

{

"id token":
"eyJhbGc101] IUzUxM1]9. eyl zdWIi01)za2FsZ3Vea2FyLiwiYXVReaCI6 I1IPTEVFVVNFULISIN
VzZXJ18eXB1Ijowl (CIncm91cHMi01tdLCI1cVyaW)i0jEsImlz cyI6ImVyd 2 1uTHIk ZWxNYXIBT1

wiahFeI joxNj E40T IxMz IyLCqdGki0iIeYzQ1N2USZ i04MALxL TOxNFLH YWQ1Z 10z NWMAOWUZ §
czMDQil C11eHAiOFE2MTg5MzU3M 19 . WY XydzeHt j8YeVEBrawPj6uloxd zPGp6L SptRUYIOSqpV
WAT9XBGANPLC52WiSoVXIbHnz Meoem I P10y TVPww"™ S
¥

8. Copy the bearer token (highlighted in the image above, content between the quotes)
and use it in your CURL command for report generation.
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Generate Reports using a Reporting Tool

Generating REST Reports

To be able to generate REST reports, ensure that you have the View permissions to the Mart
and a bearer token.

Follow these steps:
1. Run the following CURL command to authenticate yourself:

curl -X POST "http://<server
name>:18170/MartServer/api/report/authenticate™ -H
"accept: */*" -H "Authorization: Bearer <bearer token>" -H
"Content-Type:

application/Jjson" -d "

{\"password\":\"<password>\", \"username\":\"<username>\"}"
In the above command replace <server name>, <bearer token>, <username>, and
<password> with your information.

2. Run the following CURL command to generate a report:

curl -X GET "http://<server
name>:18170/MartServer/api/report/generateReport/
<predefined report
name>?additionalPropl=string&additionalProp2=string
&additionalProp3=string" -H "accept: */*" -H "Authorization:

Bearer <bearer token>"

In the above command replace <server name>, <predefined report name>, and
<bearer token> with your information.

An XML report based on the <predefined report name> parameter is generated. For
example, if you replace this parameter with Models, the following report is generated,
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Generate Reports using a Reporting Tool

where the Mart had three models available in it:

<2xml version="1.8" encoding="UTF-8" standalone="no"32:
<report_root>»

<Model>
<Id»65536</Id>
<Catalog_Name>eMovies</Catalog_MName>
<(Catalog Path>Mart<sCatalog_Path>
<CreatedOn>83/24/2821 14:85 PM<S/CreatedOn:
{UpdatedOn>83,/24/20821 14:87 PM<{/UpdatedOn:

< fModel >

<Model>
<Id>»65539</1d>
<Catalog_Name>PublicationSystemSample</Catalog_Name:>
<Catalog Path*Mart</Catalog Path»
<CreatedOn>83/24/72821 14:31 PM<SCreatedOn>
<UpdatedOn>83/24/2821 14:31 PM<SUpdatedOn:

</Model >

<Model >
<Id>65541</1d>
<Catalog Name>ReverseEngdMongoDBAfterFE</Catalog Name:>
<Catalog Path>Mart</Catalog Path>
<CreatedOn>83/2472021 14:32 PM<SCreatedOn
<UpdatedOn>83/24/72821 14:32 PM<SUpdatedOn:>

</Model >

<freport_root:>
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Creating a Custom Mart Report

Creating a Custom Mart Report

This section contains the following topics

Create Custom Mart Reports

Define a New Report

Define the Report Schema
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Create Custom Mart Reports

Create Custom Mart Reports

erwin Data Modeler (DM) Mart, version 9 onward lets you create custom Mart reports. A

custom Mart report requires two XML files, the report definition file and the report schema

file. The report definition file includes names of the tables and columns that you want to

include in the report. The report schema file includes how you want the tables and columns
to appear in the report. Sample definition and schema files are included as part of the install-

ation files.

This section describes how to edit the sample files to add new or modify existing reports.

The basic tables and columns to report are organized as shown below:

Catalog_Type
Lock Id
Id Container_|d
MName
Catalog_Id [FK) Type
User_Id (FK) i — — — Description
Cause IzsHidden
Type CreatedOn
|solation UpdatedOn
Tirne Uszer_Id (FK)
T Longld
| R _'.I Yersion
[ 1
I 1
I 1
User
d Profile_Assignment
Catalog_ld (FK)
UsEimstine Profile_Id (FK)
Ehailld User_id (FK)
UserType
IsInternal
lsDelated

Profile
Id

ls_Builtln

Object_Type

Reports on the Modeling
information. Report
information relatad to

Ohbject_Type
Star_“ersion
Catalog_MNarme
Catalog_Path
Catalog_FullPath
Catalog_Containe

Permission_Assignment

EFwin Models are to be
reported on this takle.

ﬁ Profile_d (FE)
Mame T
Description Fermission_ld (FK)

Action

MNarme

Display_MName

Pemission

Action_MNarne (FK)

Follow these steps to generate a new report:

1. Define the report definition.

2. Define the report schema.

3. Execute it using a reporting tool.

oo

Securable ]

MNarne E I

Farent_MNarme (FK)

Securable_Name (FK] &

Display_MName
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Define a New Report

Define a New Report

The reports.xml file includes report definitions for all the Mart reports. This file is available
in the MartServer\WEB-INF folder. Edit this file to modify an existing report definition or
add a new report definition.

Report definitions have the following characteristics:

" Report definitions are created in XML format.

" Reports have a unique name that identifies the report.

" Reports are defined using XML elements.

The basic XML elements and tags are shown in the example below.

Follow these steps:

1.

2
3.
4

U

Lo N

Open the MartServer\WEB-INF\Reports.xml file.
Enclose report definition within the <report> element.
Define a name for the report within the <Name> element.

Define each table that you want to include in the report. In the example below, the
report is generated on the User table.

Enclose the properties or columns of the required table that you want to appear in
the output within the <Report_Output> element.

Include all properties to report on within the <Property> element.
Define each column to report on within the <Type> tag.
Close all the tags.

(Optional) execute this report in a web browser. Use the URL for reports described in
the previous procedure.

An example of defining a report on Users is shown below:

<report>

<Name> Users </Name>

<User>
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Define a New Report
<Report Output>

<Property>
<Type>ID</Type>
<Type>Username</Type>
<Type>EmaillID</Type>
<Type>UserType</Type>
<Type>IsInternal</Type>
<Type>IsDeleted</Type>

</Property>

<Report Output>
</User>

</report>
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Define the Report Schema

Define the Report Schema

A schema defines the expected output. The report schema for all Mart reports is defined in
the reports-schema.xml file. This file is available in the MartServer\WEB-INF folder. Help
ensure that the report data output always confers to the schema definition.

Report schemas have the following characteristics:

" Report schemas are created in XML format.

" Report schemas have a unique name that identifies the schema. We recommend that

you have this name same as that of the report name.

" Reports are defined using XML elements.

Follow these steps:

1.

2
3
4,
5

Open the MartServer\WEB-INF\Reports-schema.xml file.

Enclose report schema definition within the <report_schema> element.
Define a name for the report schema within the <Name> element.
Define the Schema within the <schema> element in the CDATA section.

Defining a schema definition within the CDATA section helps XML accept the XML
related information within an XML definition.

There are various tools to generate Schema Definition (that is, XSD) inform-
ation from a XML. You can generate the schema definition using a tool of
your choice and include it in the reports-schema.xml file.

An example of defining a report schema on Users is shown below.

<report schema>

<Name> Users </Name>

<schema>

<Report Output>

<! [CDATA [<xs:schema xmlns:xs="http://www.w3.0rg/2001/XMLSchema">
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Define the Report Schema

<Xs:

<Xs

<Xs

<Xs:

<Xs:

<xXs:

<xS:

<xS:

<xS:

<xS:

<xS:

<Xs:

element name="report root">

element

:complexType>

:sequence>

name

complexType>

sequence>

element

element

element

element

element

element

name

name

name

name

name

name

</xs:sequence>

</xs:
</xs:
</xs:
</xs:

</xs:

complexType>
element>

sequence>
complexType>

element>

</xs:schema>]]>

</schema>

</report schema>

"User" maxOccurs="unbounded">

"Id" type="xs:string"/>

"Username" type="xs:string"/>
="EmailId" type="xs:string"/>

="UserType" type="xs:string"/>

"IsInternal" type="xs:string"/>

= "IsDeleted" type="xs:string"/>
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Types of Reports

Types of Reports

This section contains the following topics

Report on Catalogs

Report on Model Objects

Report on Users

Report on Locks

Report on Profiles

Report on Profile Assignments

Report on Permissions

Report on Permission Assignment

Report on Actions

Report on Securables
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Report on Catalogs

Report on Catalogs

The following types of Catalog objects are present in Mart:
" Mart
" Library
* Model

" Version
Follow these steps:

1. Edit the reports.xml file and include the report definition for the Catalog objects and
their properties that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in
the reports_schema.xml file.

The following report definition script reports on the Catalog table that includes Model
and Versions:

<report>
<Name>Library Model Version</Name>
<Catalog Type>
<Name>Model</Name>
<Report Output>
<Property>
<Type>Catalog Name</Type>
<Type>Catalog Path</Type>
</Property>
</Report Output>

<Catalog Type>
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Report on Catalogs

<Name>Version</Name>
<Report Output>
<Property>
<Type>Catalog Name</Type>
</Property>
</Report Output>
</Catalog Type>

</Catalog Type>

</report>

The list of Type tags or valid column values are listed below:

Column Name

Description

Id

Unique identifier for the catalog

Name

Name of the catalog item

Type

Type of the catalog

Container_lId

Owner of the catalog item

Catalog_Name

Name of the catalog item

Catalog_Path

Complete path for the catalog item not including the name of the catalog
item in context

Catalog_ Complete path for the catalog item including the name of the catalog item
FullPath in context

Catalog_Con- |[Name of the owner of the catalog item

tainer

Description Description of the catalog

CreatedOn Date and time identifying the catalog creation

UpdatedOn Date and time identifying the catalog latest update

User_Id User identifier responsible for creating the catalog item

Longld Identifier for the catalog

Version Version number for the catalog item
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Report on Catalogs
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Report on Model Objects

Report on Model Objects

You can report on modeling objects using the object names and property names. The list of
object names is available in the file MartServer\WEB-INF\Metadata\EMX_
ObjectTypecodelist.csv. The list of property names is available in the file MartServer\WEB-
INF\Metadata\EMX_PropertyTypecodeList.csv.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the Model objects and
their properties that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in
the reports_schema.xml file.

The following report definition script reports on the Object table that includes Entity and
Attributes:

<report>
<Name>Entity Attributes</Name>
<Object Type>
<Name>Entity</Name>
<Report Output>
<Property>
<Type>Name</Type>
<Type>Physical Name</Type>
<Type>Catalog Name</Type>
<Type>Catalog Path</Type>
</Property>

</Report Output>
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Report on Model Objects

<Object Type>
<Name>Attribute</Name>
<Report Output>
<Property>
<Type>Name</Type>
<Type>Physical Name</Type>
<Type>Logical Data Type</Type>
<Type>Physical Data Type</Type>
</Property>
</Report Output>
</Object Type>
</Object Type>
</report>

The list of Type tags or valid column values are listed below.

Column Description
Name

Catalog_Con1ldentifier for the catalog item mapped into the object table
tainer

Id GDM identifier for the object

Object_Type|Type of the object

Property Here we mention the property name to report on for example to report on
GDMTypes::pName mention Name here

Catalog_ Name of the catalog item

Name

Catalog_ Complete path for the catalog item not including the name of the catalog
Path item in context

Catalog_ Complete path for the catalog item including the name of the catalog item in
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Report on Model Objects

FullPath context

Catalog_Con{Name of the owner of the catalog item
tainer

Start_Ver- [The version that the object was created on
sion
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Additional Support for Object Type Reporting

Additional Support for Object Type Reporting

Apart from reporting on Objects and Properties, you may need to generate other reports
that need different XML elements.This section describes how you can generate reports for

special requirements.
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Alias

Alias

When generating report data in XML, the element name is the same as that defined in the
<Name> element. There may be cases when you require a different name for the element
name. In such cases, use the <Alias>Alias_Name< /Alias> tag to set the name of the element
as that defined in the Alias in the output XML. Use this name when you refer to the element
in the schema and not the name defined within the <Name> element.

Syntax:

<Alias>Alias Name</Alias>
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All Objects Support

All Objects Support

To report on an object type, use that object type within the <Name> element. To report on
all objects in Mart, do not define the <Name> element.

In the example script given below, the type of object for which the report is generated is not
mentioned. This script generates a report on all objects returning the object type, name,
and definition. Remember to add the Alias tag.

Syntax:

<report>
<Name>Definitions</Name>
<Object Type>
<Alias>Objects</Alias>
<Report Output>
<Property>
<Type>Object Type</Type>
<Type>Name</Type>
<Type>Definition</Type>
</Property>
</Report Output>
</Object Type>

</report>
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Sub Object Type Support

Sub Object Type Support

For reporting on a specific object type in a specific context, we include the <Object_Type>
tag within the parent <Object_Type> element. The supports within the sub object type sup-
port are as follows:

Child

When you define an object type within an existing object type, the child items of that spe-
cific type are reported. For example, if you report on an object type that reports an entity
that defines an object type of Attribute, then the report includes all attributes within that
entity. This is the default way in which Mart reporting is implemented.

Syntax:
<report>
<Name>Entity Attributes</Name>
<Object Type>
<Name>Entity</Name>
<Report Output>
<Property>
<Type>Name</Type>
</Property>
</Report Output>
<Object Type>
<Name>Attribute</Name>
<Report Output>
<Property>

<Type>Name</Type>
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Sub Object Type Support

</Property>
</Report Output>
</Object Type>
</Object Type>
</report>
Owner

To refer to the Owner object in the context of an object type, use the Relationship attribute
that refers to "Owner". For example, when you report on an object type that includes a
domain and defines an object type of Model with relationship attribute as "Owner," then
the report is generated on the Model owning the Domain.

Syntax:

<report>
<Name>Domains</Name>
<Object Type>
<Name>Domain</Name>
<Report Output>
<Property>
<Type>Name</Type>
</Property>
<Report Output>
<Object Type Relationship = "Owner">
<Name>Model</Name>
<Report Output>
<Property>

<Type>Name</Type>
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Sub Object Type Support

</Property>
<Report Output>
</Object Type>
</Object Type>
</report>
Referenced Object

To refer to an object that is referenced using a reference property within the object in con-
text, use the Relationship attribute as "Ref" and define another attribute Reference that
indicates the reference property to consider on the object while retrieving the object type
defined within the current object type element. For example, within an object type report-
ing on Attribute defining an object type of Domain with relationship attribute as "Ref" and
the Reference attribute defined as "Parent_Domain_Ref" would report on the Attribute and
the Domain referenced by the property "Parent_Domain_Ref" on the Attribute in context.

Syntax:
<report>
<Name>Attribute Domains</Name>
<Object Type>
<Name>Attribute</Name>
<Report Output>
<Property>
<Type>Name</Type>
</Property>
<Report Output>

<Object Type Relationship = "Ref" Reference = "Parent Domain
Ref">

<Name>Domain</Name>
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Sub Object Type Support

<Report Output>
<Property>
<Type>Name</Type>
</Property>
<Report Output>
</Object Type>
</Object Type>

</report>
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Applying Conditions

Applying Conditions

Sometimes, you apply conditions to filter data. When you apply conditions, the efficiency of
reports is improved, as conditions remove the invalid objects in context in the output XML.
The conditions are applied on the object in context. As given in the example below, the
<Condition Compare="Comparison_Strategy"> tag is defined within the <Object_Type> tag.
The "Compare" attribute defines the comparison strategy.

The comparison strategy defines the following strategies:

" Exact: Compares with the exact value defined in the <Value> tag.
BeginsWith: Value begins with the value defined in the <Value> tag.
EndsWith: Value ends with the value defined in the <Value> tag.
Contains: Value contains with the value defined in the <Value> tag.
NotEqual: Value does not match the value defined in the <Value> tag.
Null: Property value is NULL. The <Value> tag is not required in this strategy.
NotNull: Property value exists. The <Value> tag is not required in this strategy.
Syntax:

<Object Type>

<Name>Attribute</Name>

<Condition Compare = "Exact">
<Property>
<Type>Tpye</Type>
<Value>0</Value> <!--0 = PK Attribute Type-->
</Property>
</Condition>

<Report Output>

<Property>
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Applying Conditions

<Type>ID</Type>
<Type>Parent Relationship Ref</Type>
</Property>
</Report Output>

</Object Type>
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Property Type Alias

Property Type Alias

When generating report data in XML, the element name for a property is the same as that
defined in the <Type> element. There may be cases when you require a different name for
the element name; in such cases, use the <Type Alias ="Alias_Name" >Logical_Data_
Type<Type> tag to set the name of the element as that defined in the Alias in the output
XML. Use this name to refer to the element in the schema and not the name defined within
the <Type> element.

Syntax:

<Type Alias = "Datatype">Logical Data Type</Type>
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Property Inheritance Value

Property Inheritance Value

There may be a scenario when the property on an object is inherited. You can retrieve the
inherited property value using the code example given below. The Reference attribute
within the <Type> element defines the reference property to look into. The Object_Type
attribute defines the corresponding object, whereas the Property attribute defines the prop-
erty in the object to probe. The inheritance is drilled down until the property value is not
null. For example, to retrieve the Name for Domain or Attributes where the Name property
on the current domain or attribute is NULL then it gets the "Parent_Domain_Ref" on the cur-
rent object, on that id it looks into for an object of type "Domain" with the id associated
with "Parent_Domain_Ref" property and gets its property "Name". If it is NULL, it further
looks into the "Parent_Domain_Ref" property on that object and likewise looks further up
till the property is retrieved.

Syntax:
<Type Reference = "Parent Domain Ref" Object Type = "Domain" Prop-
erty = "Name">Name</Type>
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UDP Reports

UDP Reports

To generate a report on User Defined Properties (UDP) in Mart, use UDP in the <Name> ele-
ment within the <Object_Type> attribute.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of UDPs
that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in
the reports_schema.xml file.

The following example shows the report definition to report on UDPs and their properties:
Syntax:
<report>
<Name>User-Defined Properties</Name>
<Object Type>
<Name>Udp</Name>
<Report Output>
<Property>
<Type>Name</Type>
<Type>tag Udp Default Value</Type>
<Type>tag Udp Owner Type</Type>
<Type>Catalog Path</Type>
<Type>Catalog Name</Type>
</Property>

<Report Output>
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</Object Type>

</report>
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Report on Actions

This section describes how to create the report definition for actions. The Action table
stores the actions for a particular securable. For example, actions are View, Open, Save, and

SO on.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of the
Action table that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in

the reports_schema.xml file.

The following example shows the report definition to report on the Action table:
<report>
<Name>Actions</Name>
<Action>
<Report Output>
<Property>
<Type>Name</Type>
<Type>Display Name</Type>
</Property>

</Report Output>

</Action>
</report>
Column Name Description
Name Action identifier
Display_Name Display name for the action identifier
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Report on Locks

This section describes how you can create the report definition for locks.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of the
Lock table that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in
the reports_schema.xml file.

The following example shows the report definition to report on the Lock table:
<report>
<Name>Locks</Name>
<Lock>
<Report Output>
<Property>
<Type>ID</Type>
<Type>Catalog ID</Type>
<Type>Type</Type>
<Type>Time</Type>
<Type>User ID</Type>
</Property>
</Report Output>
</Lock>

</report>
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Column Description
Name
Id Unique identifier for the lock
Catalog_Id |[Catalog identifier for which the lock is applicable
User_Id User identifier that has acquired the lock
Cause The identifier of the lock that has caused this lock
Type Type of the current lock.
The values:
E: Existence
S: Shared
U: Update
X: Exclusive
Isolation Isolation level of the current lock.
The values:

C: This lock not only affects the current catalog but also all child entries of
the catalog

L: This lock only affects the current catalog

Time Date and time when the lock was applied
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Report on Permission Assignment

This section describes how you can create the report definition for permission assignments.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of the Per-
mission Assignment table that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in

the reports_schema.xml file.
The following example shows the report definition to report on the Permission Assignment

table:
<report>
<Name>Permission Assignments</Name>
<Permission Assignment>
<Report Output>
<Property>
<Type>Profile ID</Type>
<Type>Permission ID</Type>
</Property>
</Report Output>
</Permission Assignment>

</report>

Column Name |Description
Profile_Id Profile identifier for the profile

Permission_Id Permission identifier for the permission assigned on the profile
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Report on Permissions

This section describes how you can create the report definition for permissions.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of the Per-
mission table that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in

the reports_schema.xml file.

The following example shows the report definition to report on the Permission table:
<report>
<Name>Permissions</Name>
<Permission>
<Report Output>
<Property>
<Type>ID</Type>
<Type>Action Name</Type>
<Type>Securable Name</Type>
</Property>
</Report Output>

</Permission>

</report>
Column Name Description

Id Identifier for the permission
Action_Name Action associated with the permission
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Securable_Name Securable associated with the permission

Creating Custom Mart Reports| 49



Report on Profile Assignments

Report on Profile Assignments

This section describes how you can create the report definition for profile assignment.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of the Pro-
file Assignment table that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in
the reports_schema.xml file.

The following example shows the report definition to report on the Profile Assignment
table:

<report>
<Name>Profile Assignments</Name>
<Profile Assignment>
<Report Output>
<Property>
<Type>Catalog ID</Type>
<Type>Profile ID</Type>
<Type>User ID</Type>
</Property>
</Report Output>

</Profile Assignment>

</report>
Column Name Description
Catalog_|Id Identifier for the catalog for which profile is assigned
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Profile_Id

Identifier for the profile assigned

User_Id

Identifier for the User for which the profile is assigned
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Report on Profiles

This section describes how you can create the report definition for profiles.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of the Pro-
file table that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in
the reports_schema.xml file.

The following example shows the report definition to report on the Profile table:
<report>
<Name>Profiles</Name>
<Profile>

<Report Output>
<Property>
<Type>ID</Type>
<Type>Name</Type>
<Type>Description</Type>
<Type>Is BuiltIn</Type>

</Property>

</Report Output>

</Profile>
</report>
Column Name Description
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Id

Unique identifier for the profile

Name Name of the profile
Description Description associated with the profile
Is_Builtln

Integer "1" indicating if the profile is a built-in profile.
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Report on Securables

This section describes how to create the report definition for securables. The Actions table
stores the securables for a particular action. For example, actions are Mart, Model, Entity,
User Management, and so on.

Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of the
Securable table that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in
the reports_schema.xml file.

The following example shows the report definition to report on the Securable table.
<report>
<Name>Actions</Name>
<Securable>
<Report Output>
<Property>
<Type>Name</Type>
<Type>Parent Name</Type>
<Type>Display Name</Type>
</Property>
</Report Output>
</Securable>

</report>
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Column Name Description

Name Securable identifier

Parent_Name Parent securable item if any
Display_Name Display name for the securable identifier
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Report on Users

This section describes how you can create the report definition for users.
Follow these steps:

1. Edit the reports.xml file and include the report definition for the properties of the
User table that you want to report on.

2. Edit the reports_schema.xml file and include the schema definition for the report. You
can also generate the schema definition using a tool of your choice and include it in
the reports_schema.xml file.

The following example shows the report definition to report on the User table:
<report>
<Name>Users</Name>
<User>
<Report Output>
<Property>
<Type>ID</Type>
<Type>Username</Type>
<Type>EMailId</Type>
<Type>UserType</Type>
<Type>IsInternal</Type>
<Type>IsDeleted</Type>
</Property>
</Report Output>
</User>

</report>
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Column Description
Name

Id Unique identifier for the user

Username |[Username

EMailld Email address for the corresponding user

UserType |[Type of the User. The types basically are
Server User
Windows User

Group User

Isinternal |[Integer "1" indicating if the user is an internal user i.e. a windows user which
was authenticated on being part of a group user

IsDeleted |Integer "1" indicating if the user is deleted and no long a valid Mart user
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